Bluetooth Woes

It’s hard to bring myself to make discouraging remarks about a GHI product, but since the chipset is from Seeed I’ll make an exception. Just remember I mean this in a constructive criticism way. :slight_smile:

When the Bluetooth module came out I was most excited. “I’m going to use this to connect a PS3 controller to my Hydra,” I thought. But that required switching modes in a way the module couldn’t handle.

OK, I’ll buy a controller specifically made for working with tablets. No joy there either, huh?

Alright, I’ll get a Bluetooth dongle for my PC and just use it as a serial modem, stream updates or send commands or something.

What do you mean connection failed?! PC recognized it, added it to the list of connected devices, even set aside TWO serial ports for it.

Alright, maybe it was the time it took Windows to install the driver, I’ll attempt a reconnect. Nope. Remove connection manually from desktop and retry? Nope.

GHI, you make great products. You choose a bad chip for this one though. I’m now about $200 in (module/controllers/dongle) on a module that ends up being useless to me.

And before anyone says anything else, this is from Seeeds product page for the module:
“wireless connection to any other Bluetooth devices with SPP (Serial Port Profile), such as mobile phones and laptops”

There has to be a better chipset out there. One that actually allows me to, do something.

UPDATE: I have gotten it to work in Slave mode, but I’d really rather it be in Master.

Knowing you for years, I never seen you mad before so I will say this Bluetooth is really frustrating you :slight_smile: But you didn’t explain where the problem is.

Our job here is to make things better and easier, as we have always done, so just tell us what is not working.

If it is not something specific then we will do a review on the Bluetooth drivers. If your complain about needing SPP then this is standard. This is how Bluetooth work!

I am still lost on what the problem was and how we can solve this for you.

I think what’s getting me here is everything that I’ve attempted to connect to claims to SPP compliant. And since we see that the same Bluetooth dongle [em]will[/em] indeed connect to the Bluetooth Gadgeteer Module if the module is in Client mode but the module itself fails in Master mode, I have to think it’s the module’s fault and not the dongle’s.

Maybe I completely misunderstand or over-estimate the device.

And again, I want to state this isn’t against GHI and it’s not meant to be me screaming, but the chipset itself seems to fall short.

I can understand the PS3 controller not connecting or the Tablet Bluetooth SPP controller not connecting…but a Bluetooth SPP dongle for a PC, it was really disappointing. I at least can connect now w/ the module in slave mode. But I was really wanting to have the module connect to the PC, not the other way around.

Am I doing something wrong, or misunderstanding the intended use of the module?

To specifically answer your question: I should be able to connect in master mode. The dongle recognizes it, the PC recognizes it, so why can’t the module connect, even though the PC has all the required info.

Reference to previous thread about this:

@ Architect, yup I remember that. I had to manually reset the baudrate, which I was OK with. Ended up setting the module aside until just today when I got around to working w/ the new dongle for the PC.

@ Skewworks - I am still completely lost. Can you please explain what you like us to test or change?

@ Gus - Well I’m actually making some progress today, which is good. In fact it’s at a place I can feasibly use the module, but I would still like to address the Master Mode issue. So I’ll outline that for you.

  1. Connect the Bluetooth module (module from now on) to Gadgeteer mainboard of your choice.
  2. Connect Bluetooth dongle (dongle from now on) to PC/Laptop. In this case I’m using the one from Rocketfish.
  3. Set dongle to accept incoming connections
  4. Set module to Master
  5. Send \r\n+INQ=1\r\n to module
  6. Dongle reports connection request
  7. Enter pairing key
  8. Windows begins to install drivers and create serial ports
  9. During this time module reports connection failed.
  10. Repeat forever because it will never connect after this point no matter what you do.

In Slave mode it works smoothly. My concern was that I’d have to tell the PC to seek out the Slave every time. It appears this is not the case, so I am happy to continue with it as is for now.

I want to take a second to thank you Gus for helping me out here and doing whatever you can to resolve the issue. I’m still not sure if my expectations were unrealistic or the statement from Seeed about connecting to anything w/ SPP support was an exaggeration. But I know you guys will always look out for your customers. :smiley:

We will work on this next week

I have no problems like this in Client mode either. I haven’t tested Master mode at all; I don’t really need to (which doesn’t mean you shouldn’t; just I’ve not tinkered). I approached the baud rate change on the Fez end, seems to work ok; in the codeplex page I noted what I changed

I’ve successfully paired it to Win7 laptops using the Microsoft BlueTooth stack, as well as to an android tablet (Samsung Galaxy Tab 10.1) and sending serial data.

The way the Windows portion of my app works is to use the module, like @ Marco Minerva’s app at Controlling a Gadgeteer device using Bluetooth Module and 32feet.NET library | Integral Design

Without the bits, you have to remember that the BT module will pop a pairing request to the PC (again, assuming Microsoft BT stack). A simple click will get you that connected, but what you can get into is a situation where the serial ports that it connects can’t be connected and it will fail, if you have an app using the port (like TeraTerm still connected).

By any chance have any of you tried to pair it with a WP7.5 phone? I can’t get my phone to see the BT module at all. Not sure if it’s the same issue you are seeing with “compliant” devices. If not, I’ll start a new thread.

I don’t have the code I’m using right in front of me right now, but will post it tomorrow if anyone says yes.


No I’ve only paired with iPhone and Android. iPhone is the only thing I’ve found so far that the module connects to well in Master mode, though I think someone else said they managed w/ an Android.

From what I’ve read, WP7.5 doesn’t support SPP profile in Bluetooth. That’s coming in WP8.

Doh, I thought it was in 7.5. I’ll try connecting to it from my Android slate or iPad.