Been programming Cerbuino, now need to program Panda - references missing?

I went through the FEZ internet of things with the Panda II and then bought a Cerbuino. .NET 4.2 was installed and I had been programming the Cerbuino. Now I need to go back to the Panda II and I could not find the references for it. Do I need to uninstall the GHI and 4.2 stuff and reinstall 4.1 or is there a way to do both kinds of projects. I noticed the Add References accessed from the Project directory said it was filtering for 4.2. Is there a way to turn that off? I am using Visual Studio 2010.


The lastest Beta SDK supports both 4.1 and 4.2.

I am not sure what you mean? The Panda II can only be programmed with 4.1. When you
create a project which uses the Panda II all the necessary starting references should
be included in the new project.

There is a setting in the project for target framework version. I think references dialog filters out assemblies based on that setting. Make sure it is 4.1 for your Panda || project.

I changed the default framework version from 4.2 to 4.1, saved it, and it made no difference. I looked for Micro Framework project type that would allow me to select 4.1. There is only 4 which defaults to 4.2. I looked at the Gadgeteer types and there is a 4.1 and 4.2. I selected 4.1 and can now see the references I need. I will just delete all the unneeded references to Gadgeteer stuff and add the references I need and report back how it goes. I think it should work.


It compiles OK but won’t download saying "Device not found or cannot be opened - USB:Gadgeteer

I have looked in all the files and can’t find any reference to Gadgeteer, any idea where it is coming from?

As the attached screenshot shows it is USBizi_USBizi


Ok, this is weird, I changed the name of the project/program to App5 from GadgeteerApp5 and now it works.

Good! Glad it works now for you.