Main Site Documentation

Bad USB Hub! Bad! Bad!


#1

I don’t know if it was just me, or if this is generally true, but thought I’d post in case anyone else has an issue:

I tried to update the firmware on my new Domino last night, and ran into an error - Win 7 (Ultimate N 64-bit) choked when I tried to connect with the bootloader button depressed. I didn’t think to capture the actual error message, but it was a “toast”-style message that the USB device I connected had malfunctioned, and was being disabled in order to save the universe from destruction, or something to that effect.

Since [italic]a)[/italic] I’m lazy, and [italic]b)[/italic] all my equipment is mounted (well, sits on) a wire rack a good 6 feet from my desk chair, and [italic]c)[/italic] I wanted to watch the LED go blink-blink-blinkety, I had plugged the Domino into the USB hub that’s on my desk next to my monitor.

I then ran the driver install from the downloads page to no avail.

It (slowly) dawned on me that I should try plugging it directly into my PC, and Voila!, it worked like a charm.

What threw me was the fact that connecting the Domino through the hub for debugging works just fine. I’m sure there’s some arcane electronic reason for this that is painfully obvious to all you hardware guys, but be gentle - I’m a software guy - or at least, I was until last night! :slight_smile:

Thanks, GHI!

David


#2

By USB specification, a USB port must supply 500mA of current. Guess what, 90% of hubs don’t, especially those chap ones you can buy for couple bucks on ebay!
Of course, I am assuming tnat the HUB manufacture has use a USB-certified-hub-chipset and use a crystal in the right tolerance, to the USB specifications. Again, most don’t…this is how the hub is only $3!

Now, the first thing I would try is to power FEZ right from the power connector. If that solved the problem then your hub i snot supplying enough power if not then just throw the hub out of the window :slight_smile:

I usually always use “powered hubs”. These come with power pack to help the hub in powering the multiple devices.

Most people use hubs with mouse/keyboard and guess what? Those are a) do not need power so you will not see the power problem b) they are “low-speed” devices (1.5M vs 12M) so even if the crystal not within tolerance then they will probably still work.

How is that for an answer? :wink:


#3

I should have pointed out that the hub is powered. But as I said, it was just an issue when hooking it up with the bootloader button depressed - and at any rate I got the bootloader working and the firmware updated simply by plugging the Domino directly into the PC.

I’m a happy camper now - other than the fact that I don’t want to do my bill-paying work, I just want to play with my Domino! :slight_smile:

Thanks,
David


#4

Have all the fun you want then come back and tell us what you think :slight_smile:


#5

I’m using a modified cheap non-powered USB hub, running 3 devices, the FEZ being one. I have no problems as yet (touch wood) with low power.