Main Site Documentation

Bad Relay ISOx16 Module?


#1

Hi,

here are the symptoms:

  1. When I power up the Relay ISOx16 Module all relays come on. By power up I mean connecting +12V and GND to the board and nothing else connected. Is this normal?

  2. If I connect the board to FEZ Spider and power it up all relays are on (FEZ Spider is off). If I turn on FEZ Spider using USB cable or external power supply all relays turn off but while booting the Spider they come on for about 10ms and turn off again. In this scenario relays actually work properly (except for 10ms thing). Is this normal?

  3. If I unplug 12V from Relay module for a second and turn it back on everything is still normal. If I unplug it for about 10s all relays come on after plugging it back in and stay that way until I turn any relay on or off from Spider.

When I first tested relay board I had bad power supply connected as it was supplying 12V AC instead of DC (PS got damaged somehow - that’s how I discovered that PS was bad). Do you think this damaged the board? Is the board user repairable?

Thanks, Greg


#2

Thanks for quick answer. I’m still worried about all relays on for a couple of ms during the boot as this kills my project completely. Can I do anything about it?


#3

You can add pull-down resistors to ensure they are off during power up.


#4

Thanks for answers.

andre.m: My code works properly, no problems there. Edit: after another examination of the code I noticed InterruptPort in there. Thanks for this.

Architect: where would I put them? I’m not really good at electronics but I can solder pretty well :slight_smile:


#5

@ Hyperlisk - Where did you apply the 12V AC to? the gadgeteer Y socket or the relays?

The 12V AC on the Y socket could damage the 74HC595D because these are 2-6V DC, if it’s on the relays then you have nothing to worry about it. Worst case is that you burn the contacts from the relays.


#6

12V AC was straight to relay board. I think the board wasn’t even connected to gadgeeter when I did first tests but I’m not 100% sure.


#7

I don’t have the module and the schema is not completely clear to me where you had you power connected, I see the VCC is also connected to the IC’s power.

Was the 12v AC on the relays or the VCC connection?


#8

See the attacted image. It’s marked with red rectangle.


#9

This looks power input to a separate voltage regulator circuit in the corner of the relays pcb.
But can’t tell for sure, the schematic is only showing the gadgeteer module, not the relays board.


#10

Schematic is here:


#11

That’s a quit robust regulator, I doubt if you where able to damage this by applying 12VAC.

If you still have 5VDC between pin 4 and 5 on the regulator all will be ok :slight_smile:


#12

I just did some testing and there’s steady 5V between pins 4 and 5. I also tested low-level inputs and there is steady 4.9V between 5V and pins 1-16 so I guess when the board is powered it powers up all the relays. If I understand correctly I should put pull-down resistors between pins 1-16 and GND to turn them off on startup?


#13

Yes - all the led diodes on the relay board must be off when I power on the relay board.
Are 4.7k resistors enough or do I need 10k or more?


#14

So I tried putting resistors between 5V and ports 1-16, GND and ports, 5V and GND, 4.7k and 10k and nothing worked. I guess this might be too much for my electronics knowledge and maybe I should get someone more experienced to look into it :slight_smile:


#15

What electronics equipment do you have? Do you have a multimeter? If so, deploy an app that only sets relays when you interact with it, or that stops before it sets up and sets initial state of the relays (in fact, if it didn’t include relay code at all that would be fine). Measure with your multimeter the voltages you see on the control pins with your 4.7k resistors pulled to 5v and GND and see what the behaviour is.

http://homepages.which.net/~paul.hills/Software/ShiftRegister/ShiftRegisterBody.html has a decent write up on the 74HC595’s that the adapter uses to control the IO lines on the relay. There’s a comment there about using the strobe line to use the tri-state port. The GHI adapter shows that connected as “latch” so there should be no issue in doing what you are trying to do.


#16

I finally did it!!! Thanks to you all (especially Brett, David@ Emrol and andre.m).
After printing out all the schematics and that webpage with info on shift registers I finally managed to do it. All you need to do is to put resistor between 5V and pin 3 which is “Enable #” (see attached picture). A 4.7k resistor is not enough - sometimes few relays still came back on. With 10k there were no such problems. Now whenever I plug in the relay board all relays stay off!

So problem 1 solved, only one remains and I can finish my project. I would really appreciate it if anyone can help me on that one. It’s here: https://www.ghielectronics.com/community/forum/topic?id=12385


#17

cool, well done. Not sure why that works tho, but that’s my problem not yours. :slight_smile:

As for your other thread, I thought you solved it - with 3m wires? Seriously, I was not sure that it was a question… might be worth adding more detail since I originally thought you would use a physical switch on an input port.


#18

No, not solved. I don’t wanna use 14x 3m cables - too much cable.
If you open up that page you gave me there’s a picture with 47k resistor between VCC & Enable. That’s what I tried and it worked. Don’t ask me why, it just works :slight_smile: