Main Site Documentation

Bad Firmware


#1

After updating my FEZ domino to the new firmware 1.0.11, I got the error message ‘Bad firmware’ after the ‘FileTransfer Finished Successfully’ message. I’ve selected File 'USBizi_CLR.GHI (should be correct).
What happened, what have I done wrong? :o

Edit: OK, I did the update again, now it seems to work, phee :smiley:


#2

Was that with TerraTerm or the uploader by any chance?


#3

Maybe corrupt file? Download and then install the SDK again. Follow update instruction. It should work fine.


#4

I saw that also first time. I uploaded again in same session it worked. So not sure.


#5

I get this message when trying to load the firmware file in MFDeploy, is it normal ?

[quote]Exception: Unknown format at line 1 of C:\Program Files (x86)\GHI Electronics\GHI NETMF v4.1 SDK\USBizi\Firmware\USBizi_CLR.GHI:
���������xD�$o9�DzU�$o9�DzU�ym!��a-�v-�l�@ f��3;?,T#ˌ�O���j���|[/quote]


#6

No that’s not normal :stuck_out_tongue:
Did you try tore-download and re-install the SDK ?


#7

See manuals, tutorial and videos. Mfdeploy can be used only with cobra. You need xmodem


#8

The big yellow link “update your firmware” on the dl page dosn’t point to the right video IMO, it sould point to http://www.youtube.com/watch?v=a3N0nQRWb08


#9

I followed the firmware update video and after starting the xmodem send there is no progression in file transfer, it starts at 100% and stays like this.
Afterwards I get this with MFDeploy : SolutionReleaseInfo.solutionVersion: 4.1.1.0
I suppose the transfer doesn’t work, what am I doing wrong ?


#10

Maybe powers weak?


#11

After trying lots of things (powered USB, external power, another Panda, booted under Windows XP) I realized that the first time I tried to send the firmware file I might have clicked on the receive option instead of send :smiley:

After reinstalling the GHI SDK the firmware update finished correctly.


#12

lol, so you overwrote the firmware file accidentally. this is ironic.
The good thing you figured that out. :wink: