Main Site Documentation

Attempting to update FEZ Hydra results in a white background


#1

Finally found some time to start playing with this.
Downloaded the SDK (GHI NETMF v4.1 and .NET Gadgeteer Package).
Ran the Hydra firmware update tool,
Copied the boot.bin to a 512mb SD card,
Followed the instructions, on the reset my device booted with a white screen.
The firmware tool failed to detect the device when I got to step 7.
The firmware tool reports: Sig image files do not exist!
The firmware tool doesn’t detect it (tried Ping, Get Tiny Boot version, and Get Firmware version)
I’ve verified that the device is detected by windows (COM9)
I’ve unplugged the device and plugged it back end (verified device manager detects the removal/insert)
VS2010 fails to deploy code to it saying it couldn’t open/find USB:Gadgeteer

Any suggestions?

Thanks!


#2

enamtvedt, I followed the same steps that you just provided up to the point where you say this:

This too happened for me when I tested. Just click on the file open icon on the right side under Image Files and select the correct folder where the image files are located.

When I did my test, it defaulted to the file “Firmware Selection Readme.txt” as currently we provide two separate Hydra firmwares due to Ethernet not being dynamic. Just select the appropriate folder for which firmware you want and select all the files in the directory and flashing should commence for you.


#3

And don’t forget to take the SD card out, or you will end up doing the flashing twice… it happened to me :slight_smile:


#4

The firmware tool failed to detect the device when I got to step 7. => what exactly error message did you see?

And make sure you have only one device is connected.


#5

Hi all -

I just ran home on my lunch hour and tried again (this time selecting the firmware in the top right)
I get this when I get to step 7:

Connecting to device…
Cannot connect to the device! Follow steps 1 to 6
Before updating, remember:

  • Remove SD Card if you are using SD card to erase flash (after 30s since power up).
  • Disconnect between pin# 8 and pin# 3 in socket# 3 if you are connecting them together to erase flash (after 5s since power up).
  • Put JMP1 back if you are removing it to erase flash (after power up).

I’ve verified that I’ve doen steps 1-6.
The UI says for step 6 I should see a blank screen, I do - but it is solid white.

I’ve tried ping, get firmware version, and get tinyboot version from the menu, all return:
No response from device

Anything else I should try?


#6

I would try the manual version of re-flashing the board.

Put the SD card on F socket at wait a few moments. Unplug the power from the board and remove the SD card. You will need to go to the command prompt with admin access. Once in admin level command access, change your directories to get to the directory that has the UpdateFEZHydra.bat which should be: C:\Program Files (x86)\GHI Electronics\GHI OSH NETMF v4.1 SDK\FEZ Hydra\Firmware\FEZ Hydra TinyBooter Updater. Type UpdateFEZHydra comX (X being the proper com port number) and hit enter. You will have to wait a bit and a log will show up. Reset the board and TinyBooter will be present. Go to MFDeploy and select the proper firmware from the GHI Directories and you should be good to go.

This link has more detailed intructions: http://wiki.tinyclr.com/index.php?title=Firmware_Update_FEZ_Hydra


#7

Thank you for the awesome walk-thru!

I’m very close… I get an error when attempting to deploy using MFDeployer.
I selected FEZ Hydra_Gadgeteer from the USB list
Hit Ping to ensure the device was visible - Ping replied:
Pinging… TinyBooter
Bootloader build info: Copyright © GHI Electronics, LLC
I selected the ER_CONFIG, and ER_FLASH files
Hit Deploy
The tool then started erasing sectors, got to sector 0x0041df00 then displayed an error saying:
Error: Unable to deploy to device

On the device I see the following:
TinyBooter v4.1.2821.0
FEZ_Hydra Build Date:
Feb 23 2012 14:04:26
Er: 0x0041df00

Any thoughts?


#8

Do you happen to have VMWare on your computer?


#9

… VMware not, but VirtualBox yes. I’ll remove it and try again…


#10

YAY! Awesome - it works! It’s alive! Muwahahaha…

THANK YOU GUYS!