Main Site Documentation

Application doesn't work in serial debugging mode


#1
 I have a Panda II and I'm trying to use it as a USB Keyboard. When I plug in the device normally, it detects as a .NET debuggable device and I can deploy to it and it responds perfectly. When I try to set the MODE jumper to ground, all I get is the solid led light and Windows 7 don't see it as a device of any sort. The very first thing I do is turn off the LED and turn it back on in 1 second intervals to know the device is working. When it's in normal USB debugging mode, the lights flash and the device works as normal, yet when I set the jumper the lights do not blink. I believe it's the way i'm setting the jumper, not knowing exactly how to set the jumper, i'm using a wire. Is this the reason it's not behaving correctly? If so what is the proper way to set the jumper?

Thanks!


#2

What is connected to serial, you need COM1 connects to something to see what is going on. This may help http://wiki.tinyclr.com/index.php?title=USB_Client


#3

You’re not setting LDR instead of MODE by any chance are you?

Edit: also, closing a jumper point with a wire is totally acceptable, but make sure you have it reliably closed. On some other devices like Panda you can use a proper jumper as these devices just have .1" headers; these are common on PC parts as well as electronics so you might have one or more hanging around.


#4

You must also tied Rx to ground if you are not using the serial port as debug port. I think GHI miss a pullup or pulldown here… At least to me, noise is confusing the debugger and my app crash if Rx not tied to gnd.


#5

Thanks for the suggestions! The jumpers I’ve sen so far in the pc world have always been “Female”. So I wasn’t aware that there were male jumpers. I’ll so some more research and digging around to see if I can’t find one… I’ll also try the Rx thing and see if that helps… thanks!


#6

Rx to Ground worked! Thanks a million!