Main Site Documentation

An update to the non-beta SDK


#1

The SDK came out yesterday was missing the Seeed drivers int eh installer. Now they are included. We were also able to squeeze in couple things.

FEZ Hydra firmware was updated so remember to update the firmware.

Please try it and let us know. http://tinyclr.com/release-notes/


#2

Downloaded the new ZIP, installed the updated OSH SDK, and updated my Hydra firmware. I can confirm that the new release solves the issue I was having with Glide throwing an exception when loading the Window XML from a resource file.

Thanks!


#3

Does “squeeze in couple things” mean only the OSH SDK was updated (as it seems by reading the release notes)?

[edit] - saw the answer to this question in the other thread.

On a related note, I’m happy to report the WiFi module works fine on a Spider. I got a DHCP address in under 10 seconds from my access point and was able to ping the device from a PC.


#4

I went ahead and told it to reinstall everything. I got the following when it got to the Seeed install. Could it be because I had installed it manually the night before? Looks like there’s a problem in it being able to reinstall/update.

UPDATE: I tried to run the .msi manually and got the same error. I think it may be corrupt. I’m going to try downloading it again.

UPDATE 2: Downloaded and tried running the Seed .msi again and still get the error. I think the file is corrupt or has some weird security requirements. I had no problems with the version from last night.


#5

The file is not corrupt but I know what is the problem. It is the file name. Rename Seeed with Seed and run the SDK, it will work!!

I updated the zip file. Please download and try. Make sure you get a new download not somehting from your browser’s cache. You can tell it is the right one because the filename is “Seed .Net Gadgeteer SDK”. Using “Seeed .Net Gadgeteer SDK” will not work.

Hopefully this is it for a while. We need to start working on NETMF 4.2 and the many new FEZes we are developing.


#6

Well, that got me past the error but it I don’t think it actually did anything. The progress bar just went to the end of “Gathering required information…” then the setup disappeared. Maybe because it detected I had everything installed already? The other setups would have asked if I wanted to repair or uninstall.


#7

@ GHI

Is the build date for updated OSH still Jan 5? Just to want make sure that my upgrade is ok. Thank you.


#8

It is the 6th. What do you see on hydra’s screen on power up?


#9

I didn’t reboot it after deploying with MFDeploy and it was showing Jan 5. Then I removed and reapplied power and it is Jan 6 now.

I am good - thank you! :dance:


#10

HI;
I can’t find the API reference for GHI GADGETEER SDK, it is hard for me to find the class and learn how to use it.
I am depressed. I don’t know what “using” and what reference I should add in the code.


#11

@ Tzu Did you check the references here?

http://www.tinyclr.com/support/


#12

YES,but only find the GHI NETMF reference.


#13

What exactly are you looking for? If you are looking for documentation on the individual modules, you can open the designer, click on the module, and press F1 to see documentation for that module.


#14

The source code is also available, from which the xml comments can be extracted and transformed into whatever format you want.


#15

Did you try the link called “.NET Micro Framework”. It is the documentation generated by Microsoft.

http://msdn.microsoft.com/en-us/library/ee435793.aspx

There’s also this specific to Gadgeteer.

http://www.netmf.com/gadgeteer/docs/gadgeteercore/index.html


#16

Thanks a lot.