Main Site Documentation

An error occurred check your hardware, it has to get better!


#1

Hi,
Could anyone just tell me why every now and then i get this error and suddenly VS2010 refuses to deploy to my Spider…

It is frustrating, because it works fine for a while and suddenly it just won’t deploy… given that nothing was changed in the project but few lines of code…

I’ve tried resetting the board and everything you can think of… nothing…

So my questions are:
What would cause such issue?
And how can one debug the issue? once and for all…

and who is responsible for these ambiguous messages? NETMF Team, VS2010 or is it GHI?

MFDeploy can Ping just fine just so you know… i even erased the application trough MFDeploy and still get the same error.

DOES anyone at GHI get this error? and how do you circumvent it?

and here is the debug Output: Remember the same application Deployed just fine many times before and after, so My SDK’s are fine and firmware is fine and everything matches… something else is causing the issue… and we need to find out what it is… because i loose a lot of productivity time fighting with this.


Link failure: some assembly references cannot be resolved!!


Assembly: MFWsStack (4.1.2821.0) needs assembly 'System.Xml' (4.1.2821.0)

Assembly: MFWsStack (4.1.2821.0) needs assembly 'System.Http' (4.1.2821.0)

Assembly: MFWsStack (4.1.2821.0) needs assembly 'System.IO' (4.1.2821.0)

Assembly: MFWsStack (4.1.2821.0) needs assembly 'MFDpwsExtensions' (4.1.2821.0)

Assembly: MFWsStack (4.1.2821.0) needs assembly 'System' (4.1.2821.0)

Assembly: MFWsStack (4.1.2821.0) needs assembly 'Microsoft.SPOT.Net' (4.1.2821.0)

Error: a3000000

Waiting for debug commands...

thanks.

Jay.


#2

I don’t think it is a spider problem. The vs2010 tell youthat cannot find some needed assembly. Check installation of .netmf


#3

As i said above, the installation is FINE, as this works in other instances… meaning it works and then it doesn’t work using the same exact instance of VS2010… so it is the Spider i’m suspecting because right after the failed DEPLOY… if i go to MFDeploy and try to ping the Board i get


Pinging... Error: No response from device

so if reset>>ping the board is responsive… hit F5 in VS2010 >> Deploy Fails >>ping the board >> the board is no longer responsive…and requires a Reset to get it back to a responsive state… if i repeat this enough times, it deploys eventually… so something isn’t right… somewhere and i need to know what it is…

Is it an issue in the firmware???

thanks.


#4

@ Jay Jay, I sometimes get this problem, and found that the USB driver stops responding for some unknown reason, a number of times I have had to reload the USB driver. I can only think thats its due to incompatabilities with some other USB driver, thats being used at the same time. It can get really annoying.


#5

It looks more and more that it is a firmware issue and here are some more tests…
after i get error about no able to Deploy, i opened MFDeploy and Chose USB and EMX_Gadgeteer was selected now if i click on Target>>Configuration>>Network for example i get the following error (See attached screenshot)… and the T35 doesn’t show the tinybooter where usually the boards reboot and goes into tinybooter version 4.1.6.0.

so basically the firmware refuses to get into boot mode…
and the only way to get it back to a reusable state is by re-flashing the firmware…

Can someone FROM GHI please comment… so i know I’m not going nuts here…

thanks.
Jay.


#6

Start from top, have latest firmware, update firmware. Load a simple console app. Then let’s know if you have problem and where.


#7

It only takes one line of changed code to cause days of debugging! :smiley:

Usually when I have similar problems, it is being caused by an application exception occurring immediately after booting.


#8

@ GUS, after the board freezes, nothing would deploy, even if i create a new Gadgeteer application… Erasing the previous application using MFDeploy doesn’t help either…even when it is successful (the erase that is)… so the board becomes completely unusable. and the only way back is a firmware re-flash…

@ Mike: even if that is the case i should be able to get the exception instead of a frozen Board…

Which is not the case anyway, because i can Erase the Application using MFDeploy, and after a reset i get the above message… so how could my application corrupt the firmware? and how come the Spider continues to suffer from the issue after the application has been Erased using MFDeploy?

Comments???

Jay.


#9

Have you tried to add a power pack? What voltage?


#10

What do you mean, Power Pack???
are you saying i should plug BOTH my 12V 4A power Adapter and the USB cable???


#11

Yes correct.