Main Site Documentation

An error has occured: please check your hardware. VsProjectFlavorCfg


#1

This is another problem that I had ever since I use EMX.
Sometimes deployment doesn’t start and I get "An error has occured: please check your hardware"
and then

Object reference not set to an instance of an object.
Source: Microsoft.SPOT.Debugger.CorDebug
Stack :
at Microsoft.SPOT.Debugger.VsProjectFlavorCfg.Deploy() in c:\depot\current\CLIENT_V4_2\Framework\CorDebug\VsProjectFlavorCfg.cs:line 893
at Microsoft.SPOT.Debugger.VsProjectFlavorCfg.<Microsoft.VisualStudio.Shell.Interop.IVsDeployableProjectCfg.StartDeploy>b__0() in c:\depot\current\CLIENT_V4_2\Framework\CorDebug\VsProjectFlavorCfg.cs:line 634

After that no matter what I do, I can’t deploy and I get this message.
The only solution is to create a new project and copy all data. This is very annoying, so to avoid that
I keep a zipped version of a project just in case this one bombs. I’ve seen on this forum that others have
also experienced this problem and there is no solution for it. Somehow project gets corrupted ?

Thanks
M


#2

@ SFR75 - If you get a project that reproduces it, you can send it to us to take a look at to see if we can find anything.


#3

With pleasure! 8)

Where should I send it to ? Zipped it’s 690K…

M


#4

@ SFR75 - Make sure you don’t send the compiled bin or obj folders, or any emulator bits. You can send it to support at ghi… referencing this thread.


#5

@ SFR75 - We have received the project but unfortunately there wasn’t anything we could find. It did look like you were running an older 4.2 SDK and possibly VS2010. If you can I would recommend updating to at least the latest 4.2 SDK in https://www.ghielectronics.com/support/netmf/sdk/41/ghi-electronics-netmf-sdk-2016-r1 and VS2013 since numerous things have been fixed in both our firmware and Microsoft’s part since the one you’re using.