ABOR Data on boot

For some reason I all of a sudden get an ABORT DATA error when I attach power to my Hydra.

How can I restore the firmware on it? When I attach USB I just get an alert on my PC that the USB device is malfunctioning.

You can restore manually. See wiki developer page please.

Alright thanks, I got it back alive again. I tried the manual restore a number of times from my laptop but still I couldn’t come out of the USB not recognized state.

Took it to a different PC and it worked.

It just happened again while switching between debugging some code / deploying a new version of the code.
Are there any clues to why this happens?

The same happend to my Hydra-Board. My first try to restore the firmware failed too. :frowning:

Hi SylkoZ, welcome to the forum, can you show us a screen shot of your device manager when you can’t update the firmware?

I tried to restore the firmware with the Firmware-Updater from the SDK. I connected pin 8 and 10 and powered up the board and removed the wire.
A new device was found from Windows (XP with latest updates and SP). But this device keeps a “Unknown Device”. No driver found.
And the screen on hydra board was white.

When I pushed the reset button on the board it rebooted normally… and “Abort Data” again. :frowning:

I try to send a screenshot of the device manager and the display.


So, the first 3 pictures shows the device manager (in German…sorry)
The other picture is a “screeshot” of the hydra board display (T35)

What kind of USB-device should the board be during firmware update and what should happen after a power up with connected pins 8+10?

Any idea why the board is not updating?


Hi SylkoZ,

OK, that’s a Windows XP machine, right? :slight_smile: There’s a few other XP related posts with people with issues loading the drivers. First is to check the post over http://www.tinyclr.com/forum/topic?id=9388 where it says:

[quote]Also, with this release, we started using the new WinUSB drivers. No more BSoD Smiley One note on the drivers, if Windows did not detect the USB drivers automatically, just point it to C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\USB Drivers\GHI_NETMF_Interface

Please do not forget to read the release notes, especially known issues.

So it’s time to point the driver to the folder indicated above (on XP it won’t have the “(x86)” in your path)

Then, you need to finish the firmware update. It might be worth stepping through the manual process over http://wiki.tinyclr.com/index.php?title=Firmware_Update_FEZ_Hydra

let us know if that helps?

I downloaded the last SDK… this time the command line version fiexed the problem with the bootloader.

My Hydra is now on framework 4.2 and the project is runnig.