Main Site Documentation

A new SDK Release


#1

We are excited to announce the release of a new SDK! This SDK covers many bugs and adds a few new features. A full list of changes can be found at http://wiki.tinyclr.com/index.php?title=NETMF4.2_developer . For more detailed changes, please see the release notes included with the SDK.

This SDK is still under testing. If all went well, will post it right on the support page in few days.

Please be sure to sign in (on GHI main websote) then copy paste this link (link removed, download is now here http://www.ghielectronics.com/support/dotnet-micro-framework)


#2

We are not seeing the problem (never did) so it is either solved or we are not seeing it. Many things changed so please let us know if you see any issues.


#3

Initial tests with Cobra II - Able to join two different access points but getting 0.0.0.0 address. :frowning:


#4

I managed to download using link www.ghielectronics.com/download/ghi-software-package-v4.2-02142013-testing

Thank you!


#5

@ andre.m - Link should work now.


#6

Yeah, zero address here as well. Cobra II wifi is useless for me.


#7

We need ot know an exact part number of your router so we can get one and test it please. Or ship us your router :slight_smile:


#8

This statment realy concerns me… since a few people mentioned this issue. Maybe i missed something because of not an inside member…


#9

@ RobvanSchelven and @ andre.m - As explained in last reply, the fix is not a problem once we see the problem. So far we have not gotten any straight answer on “use router model 1234 and you will see the problem” We are willing to get as many routers as needed. By the way, we already got few more and tested but still every single one works perfectly.


#10

@ andre.m - Did you log in at GHI side? I was able to download it


#11

@ andre.m - Use Opera 12.x


#12

@ andre.m - maybe its the name of a map :wink:


#13

Please provide a router part number that fails so we can order one and test on our end.


#14

Re: DHCP issues

Has anyone, besides GHI, been able to use a Cobra II with WiFi reliably?

Is it possible that GHI developers are using a different hardware run?

While it could be is a router issue, more likely it is hardware or development environment issue.


#15

No argument… Everyone agrees there is an issue. We just need to work together to recreate the problem in Michigan.


#16

On my home system, with the prior SDK, I was able to reliably get a DHCP address, but was having a problem instantiating a Socket. Again, this could not be repeated in Michigan.

I think we need to send some of our Cobras back to Michigan to see if they work at their birthplace.


#17

By the way, this was added back to known issues as couple have confirmed the issue.


#18

@ GHI - Informational. Seen this message/error with 4.2.9…Not sure if its a real error in the code. I haven’t the PK installed so could not check…

LWIP Assertion “DNS response for wrong host name” failed at line 1251 in C:\MicroFrameworkPK_v4_2\DeviceCode\GHI\pal\lwip\lwip_1_3_2\src\api\api_msg.c

Must be at the hostname “mat.sentics.nl” or “time-nw.nist.gov


#19

Any small test app and setup to repro?


#20

@ Gus - Will try to create one tomorrow

Update… Issue solved … This was a result of doing a Dns.GetHostEntry in a 2nd thread… Since Dns(…) is a static class it conflicted with almost 2 calls at the same time…